CVE-2015-3415

NameCVE-2015-3415
DescriptionThe sqlite3VdbeExec function in vdbe.c in SQLite before 3.8.9 does not properly implement comparison operators, which allows context-dependent attackers to cause a denial of service (invalid free operation) or possibly have unspecified other impact via a crafted CHECK clause, as demonstrated by CHECK(0&O>O) in a CREATE TABLE statement.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3252-1
NVD severityhigh (attack range: remote)
Debian Bugs783968

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sqlite3 (PTS)wheezy3.7.13-1+deb7u2fixed
wheezy (security)3.7.13-1+deb7u4fixed
jessie3.8.7.1-1+deb8u2fixed
jessie (security)3.8.7.1-1+deb8u1fixed
stretch3.16.2-5fixed
buster, sid3.20.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sqlite3source(unstable)3.8.9-1high783968
sqlite3sourcejessie3.8.7.1-1+deb8u1highDSA-3252-1
sqlite3sourcesqueeze(not affected)
sqlite3sourcewheezy(not affected)

Notes

[wheezy] - sqlite3 <not-affected> (Vulnerable code not present)
[squeeze] - sqlite3 <not-affected> (Vulnerable code not present)
https://www.sqlite.org/src/info/02e3c88fbf6abdcf
http://seclists.org/bugtraq/2015/Apr/97

Search for package or bug name: Reporting problems