CVE-2015-3416

NameCVE-2015-3416
DescriptionThe sqlite3VXPrintf function in printf.c in SQLite before 3.8.9 does not properly handle precision and width values during floating-point conversions, which allows context-dependent attackers to cause a denial of service (integer overflow and stack-based buffer overflow) or possibly have unspecified other impact via large integers in a crafted printf function call in a SELECT statement.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3252-1, DSA-3252-2
Debian Bugs783968

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sqlite3 (PTS)bullseye3.34.1-3fixed
bookworm3.40.1-2fixed
sid, trixie3.46.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sqlitesourcebuster(not affected)
sqlitesource(unstable)(unfixed)
sqlite3sourcesqueeze(not affected)
sqlite3sourcewheezy3.7.13-1+deb7u2DSA-3252-2
sqlite3sourcejessie3.8.7.1-1+deb8u1DSA-3252-1
sqlite3source(unstable)3.8.9-1783968

Notes

[squeeze] - sqlite3 <not-affected> (Can't reproduce the issue)
[buster] - sqlite <not-affected> (vulnerable code introduced later)
http://www.sqlite.org/src/info/c494171f77dc2e5e
http://seclists.org/bugtraq/2015/Apr/97
https://lists.debian.org/debian-lts/2015/06/msg00031.html
width/precision limit safeguards are present in sqlite (V2), refactoring in V3 made it vulnerable.

Search for package or bug name: Reporting problems