DescriptionQuassel before 0.12.2 does not properly re-initialize the database session when the PostgreSQL database is restarted, which allows remote attackers to conduct SQL injection attacks via a \ (backslash) in a message. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-4422.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs783926

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quassel (PTS)jessie, jessie (security)1:0.10.0-2.3+deb8u4fixed
stretch, stretch (security)1:0.12.4-2+deb9u1fixed
buster, sid1:0.12.5-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quasselsourcesqueeze(not affected)
quasselsourcewheezy(not affected)


[wheezy] - quassel <not-affected> (incomplete fix for CVE-2013-4422 not applied)
[squeeze] - quassel <not-affected> (incomplete fix for CVE-2013-4422 not applied)

Search for package or bug name: Reporting problems