CVE-2015-3427

NameCVE-2015-3427
DescriptionQuassel before 0.12.2 does not properly re-initialize the database session when the PostgreSQL database is restarted, which allows remote attackers to conduct SQL injection attacks via a \ (backslash) in a message. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-4422.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3258-1
Debian Bugs783926

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quassel (PTS)buster1:0.13.1-1+deb10u2fixed
bullseye1:0.13.1-5fixed
bookworm1:0.14.0-1fixed
sid, trixie1:0.14.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quasselsourcesqueeze(not affected)
quasselsourcewheezy(not affected)
quasselsourcejessie1:0.10.0-2.3+deb8u1DSA-3258-1
quasselsource(unstable)1:0.10.0-2.4783926

Notes

[wheezy] - quassel <not-affected> (incomplete fix for CVE-2013-4422 not applied)
[squeeze] - quassel <not-affected> (incomplete fix for CVE-2013-4422 not applied)
https://github.com/quassel/quassel/commit/6605882f41331c80f7ac3a6992650a702ec71283
http://quassel-irc.org/node/120

Search for package or bug name: Reporting problems