CVE-2015-3429

NameCVE-2015-3429
DescriptionCross-site scripting (XSS) vulnerability in example.html in Genericons before 3.3.1, as used in WordPress before 4.2.2, allows remote attackers to inject arbitrary web script or HTML via a fragment identifier.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3328-1
NVD severitymedium (attack range: remote)
Debian Bugs784603

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10fixed
wheezy (security)3.6.1+dfsg-1~deb7u19fixed
jessie (security), jessie4.1+dfsg-1+deb8u15fixed
stretch (security), stretch4.7.5+dfsg-2+deb9u1fixed
buster, sid4.9.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.2.2+dfsg-1medium784603
wordpresssourcejessie4.1+dfsg-1+deb8u2mediumDSA-3328-1
wordpresssourcesqueeze(not affected)
wordpresssourcewheezy(not affected)

Notes

[wheezy] - wordpress <not-affected> (twentyfifteen theme not present)
[squeeze] - wordpress <not-affected> (twentyfifteen theme not present)
https://wordpress.org/news/2015/05/wordpress-4-2-2/
https://www.netsparker.com/cve-2015-3429-dom-xss-vulnerability-in-twenty-fifteen-wordpress-theme/
The default theme twentyfifteen is not present in wheezy. Upstream has
commited https://core.trac.wordpress.org/changeset/32385 though which
will enericons example.html files if present. As the file was included
in other popular themes and plugins maybe it should as well be included
in an update for wordpress for wheezy?

Search for package or bug name: Reporting problems