CVE-2015-3440

NameCVE-2015-3440
DescriptionCross-site scripting (XSS) vulnerability in wp-includes/wp-db.php in WordPress before 4.2.1 allows remote attackers to inject arbitrary web script or HTML via a long comment that is improperly stored because of limitations on the MySQL TEXT data type.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-236-1, DSA-3250-1
NVD severitymedium
Debian Bugs783554

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie4.1+dfsg-1+deb8u17fixed
jessie (security)4.1.29+dfsg-0+deb8u1fixed
stretch (security), stretch4.7.5+dfsg-2+deb9u5fixed
buster, buster (security)5.0.4+dfsg1-1+deb10u1fixed
bullseye, sid5.3.2+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.2.1+dfsg-1783554
wordpresssourcejessie4.1+dfsg-1+deb8u1DSA-3250-1
wordpresssourcesqueeze3.6.1+dfsg-1~deb6u6DLA-236-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u6DSA-3250-1

Notes

http://klikki.fi/adv/wordpress2.html
https://wordpress.org/news/2015/04/wordpress-4-2-1/
http://www.openwall.com/lists/oss-security/2015/04/27/4
https://core.trac.wordpress.org/changeset/32299

Search for package or bug name: Reporting problems