CVE-2015-3455

NameCVE-2015-3455
DescriptionSquid 3.2.x before 3.2.14, 3.3.x before 3.3.14, 3.4.x before 3.4.13, and 3.5.x before 3.5.4, when configured with client-first SSL-bump, do not properly validate the domain or hostname fields of X.509 certificates, which allows man-in-the-middle attackers to spoof SSL servers via a valid certificate.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)wheezy2.7.STABLE9-4.1+deb7u1vulnerable
wheezy (security)2.7.STABLE9-4.1+deb7u2vulnerable
squid3 (PTS)wheezy3.1.20-2.2+deb7u4vulnerable
wheezy (security)3.1.20-2.2+deb7u7vulnerable
jessie (security), jessie3.4.8-6+deb8u4vulnerable
buster, sid, stretch3.5.23-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)(unfixed)unimportant
squid3source(unstable)3.5.6-1unimportant

Notes

http://www.squid-cache.org/Advisories/SQUID-2015_1.txt
Only affects custom builds with --enable-ssl (disabled for license purposes in Debian)

Search for package or bug name: Reporting problems