CVE-2015-3646

NameCVE-2015-3646
DescriptionOpenStack Identity (Keystone) before 2014.1.5 and 2014.2.x before 2014.2.4 logs the backend_argument configuration option content, which allows remote authenticated users to obtain passwords and other sensitive backend information by reading the Keystone logs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
keystone (PTS)jessie2014.1.3-6vulnerable
stretch2:10.0.0-9fixed
buster, sid2:13.0.0-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
keystonesource(unstable)2015.1.0-1medium
keystonesourcewheezy(not affected)

Notes

[jessie] - keystone <no-dsa> (Minor issue)
[wheezy] - keystone <not-affected> (Vulnerable code not present)
Affects: versions through 2014.1.4, and 2014.2 versions through 2014.2.3

Search for package or bug name: Reporting problems