CVE-2015-3809

NameCVE-2015-3809
DescriptionThe dissect_lbmr_pser function in epan/dissectors/packet-lbmr.c in the LBMR dissector in Wireshark 1.12.x before 1.12.5 does not properly track the current offset, which allows remote attackers to cause a denial of service (infinite loop) via a crafted packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3277-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)jessie1.12.1+g01b65bf-4+deb8u14fixed
jessie (security)1.12.1+g01b65bf-4+deb8u15fixed
stretch (security), stretch2.2.6+g32dac6a-2+deb9u3fixed
buster, sid2.6.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.12.5+g5819e5b-1high
wiresharksourcejessie1.12.1+g01b65bf-4+deb8u1highDSA-3277-1
wiresharksourcesqueeze(not affected)
wiresharksourcewheezy(not affected)

Notes

[wheezy] - wireshark <not-affected> (Vulnerable code not present)
[squeeze] - wireshark <not-affected> (Vulnerable code not present)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=11036
https://www.wireshark.org/security/wnpa-sec-2015-12.html

Search for package or bug name: Reporting problems