CVE-2015-3811

NameCVE-2015-3811
Descriptionepan/dissectors/packet-wcp.c in the WCP dissector in Wireshark 1.10.x before 1.10.14 and 1.12.x before 1.12.5 improperly refers to previously processed bytes, which allows remote attackers to cause a denial of service (application crash) via a crafted packet, a different vulnerability than CVE-2015-2188.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-241-1, DSA-3277-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)wheezy1.8.2-5wheezy18fixed
wheezy (security)1.12.1+g01b65bf-4+deb8u6~deb7u7fixed
jessie (security), jessie1.12.1+g01b65bf-4+deb8u11fixed
stretch2.2.6+g32dac6a-2fixed
buster, sid2.4.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.12.5+g5819e5b-1medium
wiresharksourcejessie1.12.1+g01b65bf-4+deb8u1mediumDSA-3277-1
wiresharksourcesqueeze1.8.2-5wheezy16~deb6u1mediumDLA-241-1
wiresharksourcewheezy1.8.2-5wheezy16medium

Notes

add fixed version for wheezy directly in CVE list since CVE-2015-3811 the only fixed in DSA-3277-1
https://www.wireshark.org/security/wnpa-sec-2015-14.html
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=10978
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=a6fc6aa0b4efc1a1c3d7a2e3b5189e888fb6ccc2

Search for package or bug name: Reporting problems