CVE-2015-3991

NameCVE-2015-3991
DescriptionstrongSwan 5.2.2 and 5.3.0 allows remote attackers to cause a denial of service (daemon crash) or execute arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
strongswan (PTS)stretch5.5.1-4+deb9u4fixed
stretch (security)5.5.1-4+deb9u6fixed
buster, buster (security)5.7.2-1+deb10u2fixed
bullseye (security), bullseye5.9.1-1+deb11u2fixed
bookworm, sid5.9.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
strongswansourcesqueeze(not affected)
strongswansourcewheezy(not affected)
strongswansourcejessie(not affected)
strongswansource(unstable)5.3.0-2

Notes

[jessie] - strongswan <not-affected> (only affects 5.2.2+ and 5.3.0+)
[wheezy] - strongswan <not-affected> (only affects 5.2.2+ and 5.3.0+)
[squeeze] - strongswan <not-affected> (only affects 5.2.2+ and 5.3.0+)
http://www.strongswan.org/blog/2015/06/01/strongswan-vulnerability-(cve-2015-3991).html

Search for package or bug name: Reporting problems