CVE-2015-4004

NameCVE-2015-4004
DescriptionThe OZWPAN driver in the Linux kernel through 4.0.5 relies on an untrusted length field during packet parsing, which allows remote attackers to obtain sensitive information from kernel memory or cause a denial of service (out-of-bounds read and system crash) via a crafted packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.57-2vulnerable
stretch4.9.110-1fixed
stretch (security)4.9.110-3+deb9u3fixed
buster4.17.14-1fixed
sid4.17.17-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.3-1unimportant
linuxsourcewheezy(not affected)
linux-2.6source(unstable)(not affected)

Notes

ozwpan driver not built
[wheezy] - linux <not-affected> (ozwpan driver not present)
- linux-2.6 <not-affected> (ozwpan driver not present)
https://lkml.org/lkml/2015/5/13/739
Not enabled in Debian kernels; staging drivers are not supported
Driver was removed in Linux 4.3

Search for package or bug name: Reporting problems