CVE-2015-4017

NameCVE-2015-4017
DescriptionSalt before 2014.7.6 does not verify certificates when connecting via the aliyun, proxmox, and splunk modules.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
salt (PTS)buster, buster (security)2018.3.4+dfsg1-6+deb10u3fixed
bullseye (security), bullseye3002.6+dfsg1-4+deb11u1fixed
sid3004.1+dfsg-2.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
saltsource(unstable)(not affected)

Notes

- salt <not-affected> (Vulnerable code not present in the version in Debian stable/unstable)
https://www.openwall.com/lists/oss-security/2015/05/02/1

Search for package or bug name: Reporting problems