CVE-2015-4024

NameCVE-2015-4024
DescriptionAlgorithmic complexity vulnerability in the multipart_buffer_headers function in main/rfc1867.c in PHP before 5.4.41, 5.5.x before 5.5.25, and 5.6.x before 5.6.9 allows remote attackers to cause a denial of service (CPU consumption) via crafted form data that triggers an improper order-of-growth outcome.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3280-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
hhvm (PTS)sid3.21.0+dfsg-2fixed
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hhvmsource(unstable)3.11.0+dfsg-1medium
php5source(unstable)5.6.9+dfsg-1medium
php5sourcejessie5.6.9+dfsg-0+deb8u1mediumDSA-3280-1
php5sourcewheezy5.4.41-0+deb7u1mediumDSA-3280-1

Notes

[squeeze] - php5 <no-dsa> (Too intrusive to backport)
https://bugs.php.net/bug.php?id=69364
http://www.openwall.com/lists/oss-security/2015/05/18/2
Fixed upstream in 5.4.41, 5.5.25, 5.6.9
HHVM fix: https://github.com/facebook/hhvm/commit/6188457bd90ed2f3516e778dca8e91536d91802e

Search for package or bug name: Reporting problems