CVE-2015-4054

NameCVE-2015-4054
DescriptionPgBouncer before 1.5.5 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) by sending a password packet before a startup packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pgbouncer (PTS)stretch1.7.2-2fixed
buster1.9.0-2fixed
bullseye1.15.0-1fixed
bookworm, sid1.16.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pgbouncersourcewheezy1.5.2-4+deb7u1
pgbouncersourcejessie1.5.4-6+deb8u1
pgbouncersource(unstable)1.5.5-1

Notes

[squeeze] - pgbouncer <no-dsa> (Minor issue)
https://github.com/pgbouncer/pgbouncer/commit/edab5be6665b9e8de66c25ba527509b229468573 (master)
https://github.com/pgbouncer/pgbouncer/commit/74d6e5f7de5ec736f71204b7b422af7380c19ac5 (stable-1.5)
https://github.com/pgbouncer/pgbouncer/issues/42
https://www.openwall.com/lists/oss-security/2015/05/21/2

Search for package or bug name: Reporting problems