CVE-2015-4167

NameCVE-2015-4167
DescriptionThe udf_read_inode function in fs/udf/inode.c in the Linux kernel before 3.19.1 does not validate certain length values, which allows local users to cause a denial of service (incorrect data representation or integer overflow, and OOPS) via a crafted UDF filesystem.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-246-1, DSA-3290-1, DSA-3313-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1fixed
stretch (security)4.9.210-1+deb9u1fixed
buster4.19.146-1fixed
buster (security)4.19.152-1fixed
bullseye5.8.14-1fixed
sid5.9.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcewheezy3.2.68-1+deb7u2DSA-3290-1
linuxsourcejessie3.16.7-ckt11-1+deb8u2DSA-3313-1
linuxsource(unstable)4.0.2-1
linux-2.6sourcesqueeze2.6.32-48squeeze12DLA-246-1
linux-2.6source(unstable)(unfixed)

Notes

Upstream fix: https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=23b133bdc452aa441fcb9b82cbf6dd05cfd342d0 (v4.0-rc1)
https://www.openwall.com/lists/oss-security/2015/06/02/6

Search for package or bug name: Reporting problems