CVE-2015-4171

NameCVE-2015-4171
DescriptionstrongSwan 4.3.0 through 5.x before 5.3.2 and strongSwan VPN Client before 1.4.6, when using EAP or pre-shared keys for authenticating an IKEv2 connection, does not enforce server authentication restrictions until the entire authentication process is complete, which allows remote servers to obtain credentials by using a valid certificate and then reading the responses.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-244-1, DSA-3282-1
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
strongswan (PTS)wheezy4.5.2-1.5+deb7u8fixed
wheezy (security)4.5.2-1.5+deb7u10fixed
jessie5.2.1-6+deb8u4fixed
jessie (security)5.2.1-6+deb8u5fixed
stretch (security), stretch5.5.1-4+deb9u1fixed
buster, sid5.6.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
strongswansource(unstable)5.3.1-1low
strongswansourcejessie5.2.1-6+deb8u1lowDSA-3282-1
strongswansourcesqueeze4.4.1-5.7lowDLA-244-1
strongswansourcewheezy4.5.2-1.5+deb7u7lowDSA-3282-1

Notes

https://www.strongswan.org/blog/2015/06/08/strongswan-vulnerability-(cve-2015-4171).html

Search for package or bug name: Reporting problems