CVE-2015-4456

NameCVE-2015-4456
DescriptionownCloud Desktop Client before 1.8.2 does not call QNetworkReply::ignoreSslErrors with the list of errors to be ignored, which allows man-in-the-middle attackers to bypass the user's certificate distrust decision and obtain sensitive information by leveraging a self-signed certificate and a connection to a server using its own self-signed certificate.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3363-1
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
owncloud-client (PTS)jessie (security), jessie1.7.0~beta1+really1.6.4+dfsg-1+deb8u1fixed
stretch2.2.4+dfsg-2fixed
buster, sid2.3.3+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
owncloud-clientsource(unstable)1.8.4+dfsg-1low
owncloud-clientsourcejessie1.7.0~beta1+really1.6.4+dfsg-1+deb8u1lowDSA-3363-1

Notes

https://owncloud.org/security/advisory/?id=oc-sa-2015-009

Search for package or bug name: Reporting problems