CVE-2015-4498

NameCVE-2015-4498
DescriptionThe add-on installation feature in Mozilla Firefox before 40.0.3 and Firefox ESR 38.x before 38.2.1 allows remote attackers to bypass an intended user-confirmation requirement by constructing a crafted data: URL and triggering navigation to an arbitrary http: or https: URL at a certain early point in the installation process.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3345-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceweasel (PTS)wheezy, wheezy (security)38.8.0esr-1~deb7u1fixed
jessie (security)38.8.0esr-1~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceweaselsource(unstable)38.2.1esr-1high
iceweaselsourcejessie38.2.1esr-1~deb8u1highDSA-3345-1
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy38.2.1esr-1~deb7u1highDSA-3345-1

Notes

[squeeze] - iceweasel <end-of-life> (Not supported in Squeeze LTS)
https://www.mozilla.org/en-US/security/advisories/mfsa2015-95

Search for package or bug name: Reporting problems