CVE-2015-4506

NameCVE-2015-4506
DescriptionBuffer overflow in the vp9_init_context_buffers function in libvpx, as used in Mozilla Firefox before 41.0 and Firefox ESR 38.x before 38.3, allows remote attackers to execute arbitrary code via a crafted VP9 file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3365-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvpx (PTS)buster1.7.0-3+deb10u1fixed
buster (security)1.7.0-3+deb10u3fixed
bullseye (security), bullseye1.9.0-1+deb11u2fixed
bookworm, bookworm (security)1.12.0-1+deb12u2fixed
sid, trixie1.14.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy38.3.0esr-1~deb7u1DSA-3365-1
iceweaselsourcejessie38.3.0esr-1~deb8u1DSA-3365-1
iceweaselsource(unstable)38.3.0esr-1
libvpxsourcesqueeze(not affected)
libvpxsourcewheezy(not affected)
libvpxsource(unstable)1.4.0-4unimportant

Notes

[squeeze] - libvpx <not-affected> (no vp9 support in this version)
[wheezy] - libvpx <not-affected> (no vp9 support in this version)
https://www.mozilla.org/en-US/security/advisories/mfsa2015-101/
this is a duplicate of CVE-2015-1258, libvpx in google chrome

Search for package or bug name: Reporting problems