CVE-2015-4509

NameCVE-2015-4509
DescriptionUse-after-free vulnerability in the HTMLVideoElement interface in Mozilla Firefox before 41.0 and Firefox ESR 38.x before 38.3 allows remote attackers to execute arbitrary code via crafted JavaScript code that modifies the URI table of a media element, aka ZDI-CAN-3176.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3365-1
NVD severityhigh (attack range: remote)

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceweaselsource(unstable)38.3.0esr-1high
iceweaselsourcejessie38.3.0esr-1~deb8u1highDSA-3365-1
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy38.3.0esr-1~deb7u1highDSA-3365-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2015-106/

Search for package or bug name: Reporting problems