CVE-2015-4634

NameCVE-2015-4634
DescriptionSQL injection vulnerability in graphs.php in Cacti before 0.8.8e allows remote attackers to execute arbitrary SQL commands via the local_graph_id parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-278-1, DSA-3312-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)stretch (security), stretch0.8.8h+ds1-10+deb9u1fixed
buster1.2.2+ds1-2+deb10u4fixed
buster (security)1.2.2+ds1-2+deb10u2fixed
bullseye, sid1.2.16+ds1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisourcesqueeze0.8.7g-1+squeeze7DLA-278-1
cactisourcewheezy0.8.8a+dfsg-5+deb7u6DSA-3312-1
cactisourcejessie0.8.8b+dfsg-8+deb8u2DSA-3312-1
cactisource(unstable)0.8.8e+ds1-1

Notes

http://bugs.cacti.net/view.php?id=2577
http://svn.cacti.net/viewvc?view=rev&revision=7731

Search for package or bug name: Reporting problems