CVE-2015-4680

NameCVE-2015-4680
DescriptionFreeRADIUS 2.2.x before 2.2.8 and 3.0.x before 3.0.9 does not properly check revocation of intermediate CA certificates.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-977-1
NVD severitymedium (attack range: remote)
Debian Bugs789623

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freeradius (PTS)jessie (security), jessie2.2.5+dfsg-0.2+deb8u1vulnerable
stretch (security), stretch3.0.12+dfsg-5+deb9u1fixed
buster3.0.17+dfsg-1.1fixed
bullseye, sid3.0.19+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freeradiussource(unstable)2.2.8+dfsg-0.1medium789623
freeradiussourcewheezy2.1.12+dfsg-1.2+deb7u1mediumDLA-977-1

Notes

[jessie] - freeradius <no-dsa> (Minor issue)
[squeeze] - freeradius <no-dsa> (Minor issue)
Recommended configuration is to use self-signed CAs for EAP-TLS methods.
See raddb/certs/README
https://github.com/FreeRADIUS/freeradius-server/commit/5e698b407dcac2bc45cf03484bac4398109d25c3 (v2.x.x branch)
http://www.ocert.org/advisories/ocert-2015-008.html

Search for package or bug name: Reporting problems