DescriptionCross-site scripting (XSS) vulnerability in IPython before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the /api/notebooks path.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs789824

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ipython (PTS)jessie2.3.0-2vulnerable
bullseye, sid, buster5.8.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ipythonsourcesqueeze(not affected)
ipythonsourcewheezy(not affected)


[jessie] - ipython <no-dsa> (Minor issue)
[wheezy] - ipython <not-affected> (Problematic code introduced in rel-2.0.0)
[squeeze] - ipython <not-affected> (Problematic code introduced in rel-2.0.0)

Search for package or bug name: Reporting problems