CVE-2015-4707

NameCVE-2015-4707
DescriptionCross-site scripting (XSS) vulnerability in IPython before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the /api/notebooks path.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs789824

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ipython (PTS)jessie2.3.0-2vulnerable
stretch5.1.0-3fixed
bullseye, sid, buster5.8.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ipythonsource(unstable)2.4.1-1medium789824
ipythonsourcesqueeze(not affected)
ipythonsourcewheezy(not affected)

Notes

[jessie] - ipython <no-dsa> (Minor issue)
[wheezy] - ipython <not-affected> (Problematic code introduced in rel-2.0.0)
[squeeze] - ipython <not-affected> (Problematic code introduced in rel-2.0.0)
https://github.com/ipython/ipython/commit/1fcc9943c000ab553ebc029db99ecbd0536960d6
http://www.openwall.com/lists/oss-security/2015/06/22/4

Search for package or bug name: Reporting problems