CVE-2015-5143

NameCVE-2015-5143
DescriptionThe session backends in Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 allows remote attackers to cause a denial of service (session store consumption) via multiple requests with unique session keys.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-272-1, DSA-3305-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)wheezy1.4.5-1+deb7u16fixed
wheezy (security)1.4.22-1+deb7u3fixed
jessie (security), jessie1.7.11-1+deb8u2fixed
stretch1:1.10.7-2fixed
buster, sid1:1.11.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosource(unstable)1.7.9-1high
python-djangosourcejessie1.7.7-1+deb8u1highDSA-3305-1
python-djangosourcesqueeze1.2.3-3+squeeze13highDLA-272-1
python-djangosourcewheezy1.4.5-1+deb7u12highDSA-3305-1

Notes

https://www.djangoproject.com/weblog/2015/jul/08/security-releases/

Search for package or bug name: Reporting problems