CVE-2015-5146

NameCVE-2015-5146
Descriptionntpd in ntp before 4.2.8p3 with remote configuration enabled allows remote authenticated users with knowledge of the configuration password and access to a computer entrusted to perform remote configuration to cause a denial of service (service crash) via a NULL byte in a crafted configuration directive packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-335-1, DSA-3388-1
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ntp (PTS)wheezy1:4.2.6.p5+dfsg-2+deb7u6fixed
wheezy (security)1:4.2.6.p5+dfsg-2+deb7u7fixed
jessie (security), jessie1:4.2.6.p5+dfsg-7+deb8u2fixed
stretch1:4.2.8p10+dfsg-3+deb9u1fixed
buster, sid1:4.2.8p10+dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ntpsource(unstable)1:4.2.8p3+dfsg-1low
ntpsourcejessie1:4.2.6.p5+dfsg-7+deb8u1lowDSA-3388-1
ntpsourcesqueeze1:4.2.6.p2+dfsg-1+deb6u4lowDLA-335-1
ntpsourcewheezy1:4.2.6.p5+dfsg-2+deb7u6lowDSA-3388-1

Notes

[jessie] - ntp <no-dsa> (Minor issue)
[wheezy] - ntp <no-dsa> (Minor issue)
[squeeze] - ntp <no-dsa> (Minor issue)
http://support.ntp.org/bin/view/Main/SecurityNotice#June_2015_NTP_Security_Vulnerabi

Search for package or bug name: Reporting problems