CVE-2015-5160

NameCVE-2015-5160
Descriptionlibvirt before 2.2 includes Ceph credentials on the qemu command line when using RADOS Block Device (aka RBD), which allows local users to obtain sensitive information via a process listing.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs796111

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvirt (PTS)buster5.0.0-4+deb10u1fixed
bullseye7.0.0-3+deb11u2fixed
bookworm9.0.0-4fixed
sid, trixie10.0.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvirtsourcesqueeze(unfixed)end-of-life
libvirtsource(unstable)2.2.0-1low796111

Notes

[jessie] - libvirt <no-dsa> (Minor issue; needs changes first in QEMU)
[wheezy] - libvirt <no-dsa> (Minor issue; needs changes first in QEMU)
[squeeze] - libvirt <end-of-life> (Unsupported in squeeze-lts)
libvirt side fixed with: http://libvirt.org/git/?p=libvirt.git;a=commit;h=d53d465083edeb64cc7b78249c030734c0d91c6b
https://libvirt.org/git/?p=libvirt.git;a=commit;h=a1344f70a128921e7fe7213da7c1afbc962fba9c
and needs at least Qemu 2.6, which is satisfied in Stretch and later.
https://bugzilla.redhat.com/show_bug.cgi?id=1182074 (not yet opened)
https://www.redhat.com/archives/libvir-list/2011-November/msg00853.html
Needs changes in QEMU for passing passwords. Affects at least iSCSI and rbd/ceph.

Search for package or bug name: Reporting problems