CVE-2015-5162

NameCVE-2015-5162
DescriptionThe image parser in OpenStack Cinder 7.0.2 and 8.0.0 through 8.1.1; Glance before 11.0.1 and 12.0.0; and Nova before 12.0.4 and 13.0.0 does not properly limit qemu-img calls, which might allow attackers to cause a denial of service (memory and disk consumption) via a crafted disk image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cinder (PTS)buster2:13.0.3-1fixed
buster (security)2:13.0.7-1+deb10u2fixed
bullseye (security), bullseye2:17.0.1-1+deb11u1fixed
bookworm2:21.1.0-3fixed
sid2:23.0.0-4fixed
glance (PTS)buster2:17.0.0-4fixed
buster (security)2:17.0.0-5+deb10u1fixed
bullseye (security), bullseye2:21.0.0-2+deb11u1fixed
bookworm2:25.1.0-2fixed
sid, trixie2:27.0.0-2fixed
nova (PTS)buster2:18.1.0-6fixed
buster (security)2:18.1.0-6+deb10u2fixed
bullseye (security), bullseye2:22.0.1-2+deb11u1fixed
bookworm2:26.1.0-4fixed
sid2:28.0.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cindersource(unstable)2:8.0.0-1
glancesourcewheezy(unfixed)end-of-life
glancesource(unstable)2:12.0.0-1low
novasource(unstable)2:13.0.0-1low

Notes

[jessie] - cinder <no-dsa> (Minor issue)
[jessie] - glance <no-dsa> (Minor issue)
[wheezy] - glance <end-of-life> (not supported in Wheezy)
[jessie] - nova <no-dsa> (Minor issue)
[wheezy] - nova <no-dsa> (Minor issue)
Patches: https://www.openwall.com/lists/oss-security/2016/10/06/8

Search for package or bug name: Reporting problems