CVE-2015-5218

NameCVE-2015-5218
DescriptionBuffer overflow in text-utils/colcrt.c in colcrt in util-linux before 2.27 allows local users to cause a denial of service (crash) via a crafted file, related to the page global variable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: local)
Debian Bugs798067

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
util-linux (PTS)wheezy2.20.1-5.3vulnerable
jessie2.25.2-6vulnerable
stretch2.29.2-1fixed
buster2.30.2-0.1fixed
sid2.30.2-0.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
util-linuxsource(unstable)2.27-1unimportant798067

Notes

https://www.spinics.net/lists/util-linux-ng/msg11873.html

Search for package or bug name: Reporting problems