CVE-2015-5225

NameCVE-2015-5225
DescriptionBuffer overflow in the vnc_refresh_server_surface function in the VNC display driver in QEMU before 2.4.0.1 allows guest users to cause a denial of service (heap memory corruption and process crash) or possibly execute arbitrary code on the host via unspecified vectors, related to refreshing the server display surface.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3348-1
NVD severityhigh (attack range: local)
Debian Bugs796465

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)wheezy1.1.2+dfsg-6a+deb7u12fixed
wheezy (security)1.1.2+dfsg-6+deb7u23fixed
jessie (security), jessie1:2.1+dfsg-12+deb8u6fixed
stretch1:2.8+dfsg-6fixed
stretch (security)1:2.8+dfsg-6+deb9u2fixed
buster, sid1:2.8+dfsg-7fixed
qemu-kvm (PTS)wheezy1.1.2+dfsg-6+deb7u12fixed
wheezy (security)1.1.2+dfsg-6+deb7u23fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:2.4+dfsg-1ahigh796465
qemusourcejessie1:2.1+dfsg-12+deb8u2highDSA-3348-1
qemusourcesqueeze(not affected)
qemusourcewheezy(not affected)
qemu-kvmsource(unstable)(not affected)

Notes

[wheezy] - qemu <not-affected> (Vulnerable code introduced in 2.1.0)
[squeeze] - qemu <not-affected> (Vulnerable code introduced in 2.1.0)
- qemu-kvm <not-affected> (Vulnerable code introduced in 2.1.0)
Fix: https://lists.gnu.org/archive/html/qemu-devel/2015-08/msg02495.html
Introduced by: http://git.qemu.org/?p=qemu.git;a=commit;h=bea60dd7679364493a0d7f5b (v2.1.0-rc0)

Search for package or bug name: Reporting problems