CVE-2015-5237

NameCVE-2015-5237
Descriptionprotobuf allows remote authenticated attackers to cause a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
protobuf (PTS)stretch3.0.0-9vulnerable
buster3.6.1.3-2vulnerable
bullseye, sid3.12.3-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
protobufsource(unstable)(unfixed)unimportant

Notes

https://github.com/google/protobuf/issues/760
Upstream doesn't consider this a real issue in practice.

Search for package or bug name: Reporting problems