CVE-2015-5240

NameCVE-2015-5240
DescriptionRace condition in OpenStack Neutron before 2014.2.4 and 2015.1 before 2015.1.2, when using the ML2 plugin or the security groups AMQP API, allows remote authenticated users to bypass IP anti-spoofing controls by changing the device owner of a port to start with network: before the security group rules are applied.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
neutron (PTS)jessie2014.1.3-12vulnerable
stretch (security), stretch2:9.1.1-3+deb9u1fixed
buster2:13.0.2-15fixed
bullseye, sid2:15.0.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
neutronsource(unstable)1:7.0.0-1

Notes

[jessie] - neutron <no-dsa> (Minor issue)
versions through 2014.2.3 and 2015.1 versions through 2015.1.1

Search for package or bug name: Reporting problems