CVE-2015-5252

NameCVE-2015-5252
Descriptionvfs.c in smbd in Samba 3.x and 4.x before 4.1.22, 4.2.x before 4.2.7, and 4.3.x before 4.3.3, when share names with certain substring relationships exist, allows remote attackers to bypass intended file-access restrictions via a symlink that points outside of a share.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-379-1, DSA-3433-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)stretch2:4.5.16+dfsg-1+deb9u2fixed
stretch (security)2:4.5.16+dfsg-1+deb9u4fixed
buster, buster (security)2:4.9.5+dfsg-5+deb10u3fixed
bullseye (security), bullseye2:4.13.13+dfsg-1~deb11u3fixed
bookworm, sid2:4.16.1+dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasourcesqueeze2:3.5.6~dfsg-3squeeze13DLA-379-1
sambasourcewheezy2:3.6.6-6+deb7u6DSA-3433-1
sambasourcejessie2:4.1.17+dfsg-2+deb8u1DSA-3433-1
sambasource(unstable)2:4.1.22+dfsg-1

Notes

https://www.samba.org/samba/security/CVE-2015-5252.html

Search for package or bug name: Reporting problems