CVE-2015-5254

NameCVE-2015-5254
DescriptionApache ActiveMQ 5.x before 5.13.0 does not restrict the classes that can be serialized in the broker, which allows remote attackers to execute arbitrary code via a crafted serialized Java Message Service (JMS) ObjectMessage object.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3524-1
NVD severityhigh (attack range: remote)
Debian Bugs809733

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
activemq (PTS)wheezy5.6.0+dfsg-1+deb7u2fixed
wheezy (security)5.6.0+dfsg-1+deb7u3fixed
jessie5.6.0+dfsg1-4+deb8u3fixed
jessie (security)5.6.0+dfsg1-4+deb8u2fixed
stretch5.14.3-3fixed
buster, sid5.15.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
activemqsource(unstable)5.13.2+dfsg-1high809733
activemqsourcejessie5.6.0+dfsg1-4+deb8u2highDSA-3524-1
activemqsourcewheezy5.6.0+dfsg-1+deb7u2highDSA-3524-1

Notes

http://activemq.apache.org/security-advisories.data/CVE-2015-5254-announcement.txt
https://git-wip-us.apache.org/repos/asf?p=activemq.git;h=6f03921b31d9fefeddb0f4fa63150ed1f94a14b1 (5.11.x)
https://git-wip-us.apache.org/repos/asf?p=activemq.git;h=73a0caf758f9e4916783a205c7e422b4db27905c (5.11.x)
Patch applied to Fedora (5.6.0 based version): http://pkgs.fedoraproject.org/cgit/activemq.git/diff/activemq-5.6.0-CVE-2015-5254.patch?id=e3ef8a1b62d10273a814090be9168aa3019ace72
https://issues.apache.org/jira/browse/AMQ-6013

Search for package or bug name: Reporting problems