CVE-2015-5260

NameCVE-2015-5260
DescriptionHeap-based buffer overflow in SPICE before 0.12.6 allows guest OS users to cause a denial of service (heap-based memory corruption and QEMU-KVM crash) or possibly execute arbitrary code on the host via QXL commands related to the surface_id parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3371-1
NVD severityhigh (attack range: local)
Debian Bugs801089

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spice (PTS)wheezy0.11.0-1+deb7u2fixed
wheezy (security)0.11.0-1+deb7u4fixed
jessie (security), jessie0.12.5-1+deb8u5fixed
stretch (security), stretch0.12.8-2.1+deb9u1fixed
buster, sid0.14.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spicesource(unstable)0.12.5-1.3high801089
spicesourcejessie0.12.5-1+deb8u2highDSA-3371-1
spicesourcewheezy0.11.0-1+deb7u2highDSA-3371-1

Search for package or bug name: Reporting problems