CVE-2015-5261

NameCVE-2015-5261
DescriptionHeap-based buffer overflow in SPICE before 0.12.6 allows guest OS users to read and write to arbitrary memory locations on the host via guest QXL commands related to surface creation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3371-1
NVD severitylow (attack range: local)
Debian Bugs801091

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spice (PTS)wheezy0.11.0-1+deb7u2fixed
wheezy (security)0.11.0-1+deb7u4fixed
jessie (security), jessie0.12.5-1+deb8u5fixed
stretch (security), stretch0.12.8-2.1+deb9u1fixed
buster, sid0.13.90-0.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spicesource(unstable)0.12.5-1.3low801091
spicesourcejessie0.12.5-1+deb8u2lowDSA-3371-1
spicesourcewheezy0.11.0-1+deb7u2lowDSA-3371-1

Search for package or bug name: Reporting problems