CVE-2015-5279

NameCVE-2015-5279
DescriptionHeap-based buffer overflow in the ne2000_receive function in hw/net/ne2000.c in QEMU before 2.4.0.1 allows guest OS users to cause a denial of service (instance crash) or possibly execute arbitrary code via vectors related to receiving packets.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3361-1, DSA-3362-1
NVD severityhigh (attack range: local)
Debian Bugs799074

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)wheezy1.1.2+dfsg-6a+deb7u12fixed
wheezy (security)1.1.2+dfsg-6+deb7u23fixed
jessie, jessie (security)1:2.1+dfsg-12+deb8u6fixed
stretch1:2.8+dfsg-6fixed
stretch (security)1:2.8+dfsg-6+deb9u2fixed
buster, sid1:2.8+dfsg-7fixed
qemu-kvm (PTS)wheezy1.1.2+dfsg-6+deb7u12fixed
wheezy (security)1.1.2+dfsg-6+deb7u23fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:2.4+dfsg-3high799074
qemusourcejessie1:2.1+dfsg-12+deb8u4highDSA-3361-1
qemusourcesqueeze(unfixed)end-of-life
qemusourcewheezy1.1.2+dfsg-6a+deb7u11highDSA-3361-1
qemu-kvmsource(unstable)(unfixed)high
qemu-kvmsourcesqueeze(unfixed)end-of-life
qemu-kvmsourcewheezy1.1.2+dfsg-6+deb7u11highDSA-3362-1

Notes

[squeeze] - qemu <end-of-life> (Not supported in Squeeze LTS)
[squeeze] - qemu-kvm <end-of-life> (Not supported in Squeeze LTS)
https://lists.gnu.org/archive/html/qemu-devel/2015-09/msg03984.html

Search for package or bug name: Reporting problems