CVE-2015-5292

NameCVE-2015-5292
DescriptionMemory leak in the Privilege Attribute Certificate (PAC) responder plugin (sssd_pac_plugin.so) in System Security Services Daemon (SSSD) 1.10 before 1.13.1 allows remote authenticated users to cause a denial of service (memory consumption) via a large number of logins that trigger parsing of PAC blobs during Kerberos authentication.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sssd (PTS)wheezy1.8.4-2fixed
jessie1.11.7-3vulnerable
stretch1.15.0-3fixed
buster1.15.3-1fixed
sid1.15.3-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sssdsource(unstable)1.13.1-1medium
sssdsourcesqueeze(not affected)
sssdsourcewheezy(not affected)

Notes

[jessie] - sssd <no-dsa> (Minor issue; responder not built)
binary package has the sssd_pac_plugin.so but the responder
part is not build.
[wheezy] - sssd <not-affected> (vulnerable code not present)
[squeeze] - sssd <not-affected> (vulnerable code not present)
https://fedorahosted.org/sssd/ticket/2803
https://fedorahosted.org/sssd/attachment/ticket/2803/0001-Fix-memory-leak-in-sssdpac_verify.patch

Search for package or bug name: Reporting problems