CVE-2015-5297

NameCVE-2015-5297
DescriptionAn integer overflow issue has been reported in the general_composite_rect() function in pixman prior to version 0.32.8. An attacker could exploit this issue to cause an application using pixman to crash or, potentially, execute arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1587-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pixman (PTS)stretch0.34.0-1fixed
buster0.36.0-1fixed
bullseye, sid0.40.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pixmansourcejessie0.32.6-3+deb8u1DLA-1587-1
pixmansource(unstable)0.33.4-1

Notes

https://bugs.freedesktop.org/show_bug.cgi?id=92027
Patch: https://cgit.freedesktop.org/pixman/patch/?id=204fcd24d9b7e3988b7496e723014f327828751a

Search for package or bug name: Reporting problems