CVE-2015-5309

NameCVE-2015-5309
DescriptionInteger overflow in the terminal emulator in PuTTY before 0.66 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via an ECH (erase characters) escape sequence with a large parameter value, which triggers a buffer underflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-347-1, DSA-3409-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
putty (PTS)wheezy, wheezy (security)0.62-9+deb7u3fixed
jessie (security), jessie0.63-10+deb8u1fixed
stretch0.67-3fixed
buster, sid0.70-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puttysource(unstable)0.66-1medium
puttysourcejessie0.63-10+deb8u1mediumDSA-3409-1
puttysourcesqueeze0.60+2010-02-20-1+squeeze4mediumDLA-347-1
puttysourcewheezy0.62-9+deb7u3mediumDSA-3409-1

Notes

http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/vuln-ech-overflow.html
http://tartarus.org/~simon-git/gitweb/?p=putty.git;a=commitdiff;h=6056396f77cafc7e40da4d09f1d6212408dcb065

Search for package or bug name: Reporting problems