CVE-2015-5311

NameCVE-2015-5311
DescriptionPowerDNS (aka pdns) Authoritative Server 3.4.4 before 3.4.7 allows remote attackers to cause a denial of service (assertion failure and server crash) via crafted query packets.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns (PTS)jessie3.4.1-4+deb8u8fixed
jessie (security)3.4.1-4+deb8u10fixed
stretch (security), stretch4.0.3-1+deb9u5fixed
buster4.1.6-3fixed
bullseye, sid4.2.1-1fixed
pdns-recursor (PTS)jessie3.6.2-2+deb8u4fixed
jessie (security)3.6.2-2+deb8u3fixed
stretch4.0.4-1+deb9u4fixed
stretch (security)4.0.4-1+deb9u3fixed
buster4.1.11-1fixed
bullseye, sid4.2.0-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdnssource(unstable)3.4.7-1
pdnssourcejessie(not affected)
pdnssourcesqueeze(not affected)
pdnssourcewheezy(not affected)
pdns-recursorsource(unstable)(not affected)

Notes

[jessie] - pdns <not-affected> (Only 3.4.4 and later affected)
[wheezy] - pdns <not-affected> (Only 3.4.4 and later affected)
[squeeze] - pdns <not-affected> (Only 3.4.4 and later affected)
- pdns-recursor <not-affected> (recursor not affected)
http://www.openwall.com/lists/oss-security/2015/11/09/3

Search for package or bug name: Reporting problems