DescriptionPowerDNS (aka pdns) Authoritative Server 3.4.4 before 3.4.7 allows remote attackers to cause a denial of service (assertion failure and server crash) via crafted query packets.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns (PTS)stretch (security), stretch4.0.3-1+deb9u5fixed
bullseye, sid4.3.0-4fixed
pdns-recursor (PTS)stretch4.0.4-1+deb9u4fixed
stretch (security)4.0.4-1+deb9u3fixed
buster (security)4.1.11-1+deb10u1fixed
bullseye, sid4.3.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdnssourcejessie(not affected)
pdnssourcesqueeze(not affected)
pdnssourcewheezy(not affected)
pdns-recursorsource(unstable)(not affected)


[jessie] - pdns <not-affected> (Only 3.4.4 and later affected)
[wheezy] - pdns <not-affected> (Only 3.4.4 and later affected)
[squeeze] - pdns <not-affected> (Only 3.4.4 and later affected)
- pdns-recursor <not-affected> (recursor not affected)

Search for package or bug name: Reporting problems