CVE-2015-5343

NameCVE-2015-5343
DescriptionInteger overflow in util.c in mod_dav_svn in Apache Subversion 1.7.x, 1.8.x before 1.8.15, and 1.9.x before 1.9.3 allows remote authenticated users to cause a denial of service (subversion server crash or memory consumption) and possibly execute arbitrary code via a skel-encoded request body, which triggers an out-of-bounds read and heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3424-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
subversion (PTS)wheezy1.6.17dfsg-4+deb7u10fixed
wheezy (security)1.6.17dfsg-4+deb7u12fixed
jessie (security), jessie1.8.10-6+deb8u5fixed
stretch (security), stretch1.9.5-1+deb9u1fixed
buster, sid1.9.7-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
subversionsource(unstable)1.9.3-1high
subversionsourcejessie1.8.10-6+deb8u2highDSA-3424-1
subversionsourcesqueeze(not affected)
subversionsourcewheezy(not affected)

Notes

[wheezy] - subversion <not-affected> (Vulnerable code not present)
[squeeze] - subversion <not-affected> (Vulnerable code not present)
https://subversion.apache.org/security/CVE-2015-5343-advisory.txt

Search for package or bug name: Reporting problems