CVE-2015-5345

NameCVE-2015-5345
DescriptionThe Mapper component in Apache Tomcat 6.x before 6.0.45, 7.x before 7.0.68, 8.x before 8.0.30, and 9.x before 9.0.0.M2 processes redirects before considering security constraints and Filters, which allows remote attackers to determine the existence of a directory via a URL that lacks a trailing / (slash) character.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-435-1, DSA-3530-1, DSA-3552-1, DSA-3609-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tomcat6 (PTS)jessie (security), jessie6.0.45+dfsg-1~deb8u1fixed
tomcat7 (PTS)jessie7.0.56-3+deb8u11fixed
jessie (security)7.0.56-3+really7.0.94-1fixed
stretch7.0.75-1fixed
tomcat8 (PTS)jessie8.0.14-1+deb8u11fixed
jessie (security)8.0.14-1+deb8u15fixed
stretch (security), stretch8.5.14-1+deb9u3fixed
tomcat9 (PTS)buster9.0.16-4fixed
bullseye, sid9.0.27-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tomcat6source(unstable)6.0.41-3
tomcat6sourcesqueeze6.0.45-1~deb6u1DLA-435-1
tomcat6sourcewheezy6.0.45+dfsg-1~deb7u1DSA-3530-1
tomcat7source(unstable)7.0.68-1
tomcat7sourcejessie7.0.56-3+deb8u2DSA-3552-1
tomcat7sourcewheezy7.0.28-4+deb7u4DSA-3552-1
tomcat8source(unstable)8.0.30-1
tomcat8sourcejessie8.0.14-1+deb8u2DSA-3609-1
tomcat9source(unstable)(not affected)

Notes

- tomcat9 <not-affected> (Fixed before initial upload to Debian)
Since 6.0.41-3, src:tomcat6 only builds a servlet and docs
Fixed in 6.0.45, 7.0.67, 8.0.30, 9.0.0.M3

Search for package or bug name: Reporting problems