CVE-2015-5622

NameCVE-2015-5622
DescriptionCross-site scripting (XSS) vulnerability in WordPress before 4.2.3 allows remote authenticated users to inject arbitrary web script or HTML by leveraging the Author or Contributor role to place a crafted shortcode inside an HTML element, related to wp-includes/kses.php and wp-includes/shortcodes.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-294-1, DSA-3332-1, DSA-3383-1
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10fixed
wheezy (security)3.6.1+dfsg-1~deb7u19fixed
jessie, jessie (security)4.1+dfsg-1+deb8u15fixed
stretch, stretch (security)4.7.5+dfsg-2+deb9u1fixed
buster, sid4.9.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.2.3+dfsg-1low
wordpresssourcejessie4.1+dfsg-1+deb8u4lowDSA-3332-1
wordpresssourcesqueeze3.6.1+dfsg-1~deb6u7lowDLA-294-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u8lowDSA-3383-1

Notes

https://core.trac.wordpress.org/changeset/33359

Search for package or bug name: Reporting problems