CVE-2015-5623

NameCVE-2015-5623
DescriptionWordPress before 4.2.3 does not properly verify the edit_posts capability, which allows remote authenticated users to bypass intended access restrictions and create drafts by leveraging the Subscriber role, as demonstrated by a post-quickdraft-save action to wp-admin/post.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3328-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)stretch4.7.5+dfsg-2+deb9u6fixed
stretch (security)4.7.23+dfsg-0+deb9u1fixed
buster, buster (security)5.0.15+dfsg1-0+deb10u1fixed
bullseye (security), bullseye5.7.5+dfsg1-0+deb11u1fixed
bookworm, sid5.9.2+dfsg1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssourcesqueeze(not affected)
wordpresssourcewheezy(not affected)
wordpresssourcejessie4.1+dfsg-1+deb8u2DSA-3328-1
wordpresssource(unstable)4.2.3+dfsg-1

Notes

[wheezy] - wordpress <not-affected> (Vulnerable code not present)
[squeeze] - wordpress <not-affected> (Vulnerable code not present)
https://core.trac.wordpress.org/changeset/33357

Search for package or bug name: Reporting problems