CVE-2015-5705

NameCVE-2015-5705
DescriptionArgument injection vulnerability in devscripts before 2.15.7 allows remote attackers to write to arbitrary files via a crafted symlink and crafted filename.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs794365

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
devscripts (PTS)stretch2.17.6+deb9u2fixed
buster2.19.5+deb10u1fixed
bullseye, sid2.21.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
devscriptssourcesqueeze(not affected)
devscriptssourcewheezy(not affected)
devscriptssourcejessie(not affected)
devscriptssource(unstable)2.15.8794365

Notes

[jessie] - devscripts <not-affected> (Vulnerable code not present)
[wheezy] - devscripts <not-affected> (Vulnerable code not present)
[squeeze] - devscripts <not-affected> (Vulnerable code not present)
Introduced in https://anonscm.debian.org/cgit/collab-maint/devscripts.git/commit/?id=025ad4ea8ba92d32bd698a83149f782c17f78bf0 (v2.15.5)

Search for package or bug name: Reporting problems