CVE-2015-5715

NameCVE-2015-5715
DescriptionThe mw_editPost function in wp-includes/class-wp-xmlrpc-server.php in the XMLRPC subsystem in WordPress before 4.3.1 allows remote authenticated users to bypass intended access restrictions, and arrange for a private post to be published and sticky, via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-321-1, DSA-3375-1, DSA-3383-1
NVD severitymedium (attack range: remote)
Debian Bugs799140

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10fixed
wheezy (security)3.6.1+dfsg-1~deb7u16fixed
jessie4.1+dfsg-1+deb8u14fixed
jessie (security)4.1+dfsg-1+deb8u15fixed
stretch4.7.5+dfsg-2fixed
stretch (security)4.7.5+dfsg-2+deb9u1fixed
buster, sid4.8.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.3.1+dfsg-1medium799140
wordpresssourcejessie4.1+dfsg-1+deb8u5mediumDSA-3375-1
wordpresssourcesqueeze3.6.1+dfsg-1~deb6u8mediumDLA-321-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u8mediumDSA-3383-1

Notes

https://wordpress.org/news/2015/09/wordpress-4-3-1/
https://github.com/WordPress/WordPress/commit/9c57f3a4291f2311ae05f22c10eedeb0f69337ab

Search for package or bug name: Reporting problems