CVE-2015-5730

NameCVE-2015-5730
DescriptionThe sanitize_widget_instance function in wp-includes/class-wp-customize-widgets.php in WordPress before 4.2.4 does not use a constant-time comparison for widgets, which allows remote attackers to conduct a timing side-channel attack by measuring the delay before inequality is calculated.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3332-1
NVD severitymedium (attack range: remote)
Debian Bugs794560

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10fixed
wheezy (security)3.6.1+dfsg-1~deb7u16fixed
jessie4.1+dfsg-1+deb8u14fixed
jessie (security)4.1+dfsg-1+deb8u15fixed
stretch4.7.5+dfsg-2fixed
stretch (security)4.7.5+dfsg-2+deb9u1fixed
buster, sid4.8.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.2.4+dfsg-1medium794560
wordpresssourcejessie4.1+dfsg-1+deb8u4mediumDSA-3332-1
wordpresssourcesqueeze(not affected)
wordpresssourcewheezy(not affected)

Notes

[squeeze] - wordpress <not-affected> (Vulnerable code introduced later)
[wheezy] - wordpress <not-affected> (Vulnerable code introduced later)
https://core.trac.wordpress.org/changeset/33535
https://core.trac.wordpress.org/changeset/33536

Search for package or bug name: Reporting problems