CVE-2015-5732

NameCVE-2015-5732
DescriptionCross-site scripting (XSS) vulnerability in the form function in the WP_Nav_Menu_Widget class in wp-includes/default-widgets.php in WordPress before 4.2.4 allows remote attackers to inject arbitrary web script or HTML via a widget title.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-294-1, DSA-3332-1, DSA-3383-1
NVD severitymedium (attack range: remote)
Debian Bugs794560

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10fixed
wheezy (security)3.6.1+dfsg-1~deb7u16fixed
jessie4.1+dfsg-1+deb8u14fixed
jessie (security)4.1+dfsg-1+deb8u15fixed
stretch4.7.5+dfsg-2fixed
stretch (security)4.7.5+dfsg-2+deb9u1fixed
buster, sid4.8.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.2.4+dfsg-1medium794560
wordpresssourcejessie4.1+dfsg-1+deb8u4mediumDSA-3332-1
wordpresssourcesqueeze3.6.1+dfsg-1~deb6u7mediumDLA-294-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u8mediumDSA-3383-1

Notes

https://core.trac.wordpress.org/changeset/33529

Search for package or bug name: Reporting problems