CVE-2015-6496

NameCVE-2015-6496
Descriptionconntrackd in conntrack-tools 1.4.2 and earlier does not ensure that the optional kernel modules are loaded before using them, which allows remote attackers to cause a denial of service (crash) via a (1) DCCP, (2) SCTP, or (3) ICMPv6 packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-295-1, DSA-3341-1
NVD severitymedium (attack range: remote)
Debian Bugs796103

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
conntrack (PTS)wheezy, wheezy (security)1:1.2.1-1+deb7u1fixed
jessie (security), jessie1:1.4.2-2+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
conntracksource(unstable)1:1.4.2-3medium796103
conntracksourcejessie1:1.4.2-2+deb8u1mediumDSA-3341-1
conntracksourcesqueeze1:0.9.14-2+deb6u1mediumDLA-295-1
conntracksourcewheezy1:1.2.1-1+deb7u1mediumDSA-3341-1

Notes

http://www.openwall.com/lists/oss-security/2015/08/14/4
http://bugzilla.netfilter.org/show_bug.cgi?id=910
https://git.netfilter.org/conntrack-tools/commit/?id=c392c159605956c7bd4a264ab4490e2b2704c0cd

Search for package or bug name: Reporting problems