CVE-2015-6525

NameCVE-2015-6525
DescriptionMultiple integer overflows in the evbuffer API in Libevent 2.0.x before 2.0.22 and 2.1.x before 2.1.5-beta allow context-dependent attackers to cause a denial of service or possibly have other unspecified impact via "insanely large inputs" to the (1) evbuffer_add, (2) evbuffer_prepend, (3) evbuffer_expand, (4) exbuffer_reserve_space, or (5) evbuffer_read function, which triggers a heap-based buffer overflow or an infinite loop. NOTE: this identifier was SPLIT from CVE-2014-6272 per ADT3 due to different affected versions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3119-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libevent (PTS)wheezy2.0.19-stable-3+deb7u1fixed
wheezy (security)2.0.19-stable-3+deb7u2fixed
jessie (security), jessie2.0.21-stable-2+deb8u1fixed
stretch2.0.21-stable-3fixed
buster, sid2.1.8-stable-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libeventsource(unstable)2.0.21-stable-2high
libeventsourcesqueeze(not affected)
libeventsourcewheezy2.0.19-stable-3+deb7u1highDSA-3119-1

Notes

[squeeze] - libevent <not-affected> (Only for issues in 2.0.x and 2.1.x)
Split from CVE-2014-6272

Search for package or bug name: Reporting problems